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Note: All measurements in this instrument driver reference have been performed with the latest 

Bode Automation (SCPI & API). Use this version or a higher version to perform the 
measurements shown in this document. You can download the latest version at  
https://www.omicron-lab.com/downloads/bode-analyzer-suite under Automation. 

https://www.omicron-lab.com/downloads/bode-analyzer-suite
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1 Introduction 
This document briefly introduces the Bode 100 and Bode 500 Instrument Driver for LabVIEW1. 
Furthermore, it shows a simple example of connecting to a Bode 100 device and measuring the 
frequency response (Gain/Phase) of the IF filter circuit board delivered with the Bode 100 and Bode 
500. The examples described in this manual can also be performed using the Bode 500. 
You can follow the steps in this document or run the “Bode VNA Series Step by Step Gain 
Measurement.vi” from the Examples folder. 

2 Requirements 

2.1   System 

Please check the system requirements on:  
• https://www.ni.com/en.html 
• https://www.omicron-lab.com/downloads/bode-analyzer-suite 

2.2   Software 

• Either the latest Bode Analyzer Suite OR the latest Bode Automation Interface which includes 
SCPI server for Bode 100 
 

 Notice 
The SCPI Server is part of the Bode 500 device and is active by default. 

 
• LabVIEW 2013 (or higher)  

2.3   Hardware 

• Bode 100 (Revision 1 or Revision 2) and/or Bode 500 device. 
• IF Filter test board (delivered with Bode 100 and Bode 500 device) 

  

 
1 LabVIEW is a registered trademark of the National Instruments Corporation. 

https://www.ni.com/en.html
https://www.omicron-lab.com/downloads/bode-analyzer-suite
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3 Getting Started: OMICRON Lab Bode VNA Driver 

3.1   Connect Bode device 

Connect the Bode to the IF Filter test board as shown in Figure 1. 
 

 
Figure 1: Connection Example of IF filter to Bode 100 

3.2   Install Bode VNA Series Instrument Driver 

To install the OMICRON Lab Bode VNA Series Instrument Driver (Bode VNA Driver) on your PC, 
download the LabVIEW driver package from https://www.ni.com/en/support/downloads/instrument-
drivers.html by searching for “OMICRON Lab Bode VNA Series”. Extract the package into the 
LabVIEW “instr.lib” folder (Figure 2), which can be found in the location of your LabVIEW installation 
folder: < LabVIEW installation folder\instr.lib>. 
 

 
Figure 2: OMICRON Lab Bode VNA Series 

  

https://www.ni.com/en/support/downloads/instrument-drivers.html
https://www.ni.com/en/support/downloads/instrument-drivers.html
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A more elegant way to install the Bode VNA Series Instrument Driver would be to use the “NI 
Instrument Driver finder” under “Tools → Instrumentation → Find Instrument Drivers…” (Figure 3). 
 

Figure 3: Find Instrument Drivers 
 
Launch LabVIEW to initialize the driver automatically after the package installation. The driver’s menu 
palette can be found in the Block Diagram window, located under the function menu palette 
“Instrument I/O → Instrument Drivers” (Figure 4). The installation is successful if the if the “OMICRON 
Lab Bode VNA Series” sub-palette icon is visible. 
 

 
Figure 4: Bode VNA Driver in the Instrument Drivers Palette 
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3.3   Measurement and Configuration Structure of Bode 

Figure 5 illustrates a potential measurement workflow utilizing the OMICRON Lab Bode VNA Series Instrument Driver. 
To connect with a Bode device, use “Initialize.vi” to facilitate communication with the instrument. 
Once connected, it is possible to configure the device and perform both measurements and calibrations. 
 
Always execute the measurement to obtain measurement result data in the desired format. 
 
Finally, disconnect from the Bode device using “Close.vi”. 
 

 
Figure 5: Possible measurement workflow 
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3.4   Gain/Phase Measurement Example 

The example in this document shows a Gain / Phase measurement with the OMICRON Lab Bode 
VNA Series Instrument Driver, resulting in the gain magnitude diagram of the quartz filter.  
 
Notice 
In this example no calibration is performed. 

 
Firstly, open LabVIEW and create a “blank new VI”.  
Subsequently, two windows appear:  

1. one for operation (front panel) and  
2. the other for the functionality and sequence (block diagram) of the VI. 

 
Navigate now to the "Block Diagram" window and open the function palette. 
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3.4.1  Connect to the Bode device 

The initial step to obtaining a functional Gain / Phase measurement involves connecting an available 
Bode device. This can be either a Bode 100 or a Bode 500 device. 
A Bode device can be connected using the “Initialize.vi” as shown in Figure 6.  
“Initialize.vi” establishes communication with the instrument and optionally performs an instrument 
identification query and/or an instrument reset. 
 
Notice 
“Initialize” also locks the device. 

 

 
Figure 6: Bode VNA Driver – Initialize.vi 

 
In the previous driver version (Bode 100), it was necessary to place “ScanForFreeDevices.vi” and 
“Connect.vi” on the block diagram window and wire them together (Figure 7). 
 

 
Figure 7: Previous driver (Bode 100) -  

Communication with the instrument 

 
 

 
Figure 8: Current driver- Communication with the instrument 

 
In the current driver version, only the “Initialize.vi” is required (Figure 8). The “SERIAL NUMBER” 
indicator retrieves the serial number of the connected device, which is particularly useful when 
multiple Bode devices are connected to the PC. 
 
Notice 
The device selection is now part of the "VISA IN" control. An elegant way to configure a device would 
be by adding it via NI MAX. Follow the Bode Automation and SCPI Documentation link for more 
information 

 
.   

https://documentation.omicron-lab.com/BodeAutomationInterface/3.51/articlesScpi/general/setupConnection.html?tabs=setup-csharp
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3.4.2  Create and Configure a Measurement 

The subsequent steps involve the  
1. creation and configuration of the hardware setup,  
2. as well as the configuration of the sweep measurement – in our example a Gain/Phase 

measurement. 
 

 
Figure 9: Measurement palette – “ConfigureTransmissionMeasurements.vi”  

 
In the previous driver version (Bode 100), the measurement is created by wiring the “Connect.vi” with 
the "CreateMeasurement.vi" (Figure 10). 
 

 
 

 
 

Figure 10: Previous driver (Bode 100) -  
“Create Measurement.vi” 

Figure 11: Current driver –  
“Configure Gain/PhaseMeasurement.vi” 

 
In the current driver version, the updated driver requires the use of “Configure Transmission 
Measurements.vi” to create a measurement (Figure 9) and (Figure 11). 
 
The default setting is an S21 measurement using “Configure Transmission Measurements.vi”. To 
select the gain / phase measurement, use the polymorphic selector as shown in the (Figure 11). 
 
Notice 
• Depending on the selected “Measurement Format”, the receiving result exists of primary data  

(see example) or primary and secondary data. See also section 3.4.5 Receiving Measurement 
Results. 

• Besides Gain/Pahse measurements it is also possible to configure impedance measurements 
(“Configure Impedance Measurements.vi”) and absolute measurements (“Configure Absolute 
Measurement.vi”). 

  



Getting started with LabVIEW 
Page 10 of 23 

  

Smart Measurement Solutions Smart Measurement Solutions® 

3.4.3  Configure Hardware and Measurement Setup 

As the next step, configure the hardware and measurement settings as frequency range, source level, 
number of measurement points, bandwidth or attenuation. If needed, individual controls can be 
added.  
In this example the following VIs are added (Figure 12) and connected (Figure 13): 

• "Configure Stimulus Sweep.vi",  
• "Configure Sweep.vi",  
• “Configure IF Bandwith.vi” and  
• “Configure Attenuation.vi” 

 

 
Figure 12: Measurement Palette – Configure Hardware 
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Figure 13: Configuration of hardware setup – Block Diagram 

 
To add a control, right-click on the respective VI input and select "Create" -> "Control”. This control 
will also appear in the front panel window, where it can be edited. 
 
Notice 
A special control is available to handle MIN/MAX values besides standard values. When selecting 
MIN/MAX, the minimal/maximal value will be used, supported by the connected device. Otherwise, 
the value chosen in the "Value” control will be used. 
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3.4.4  Execute Measurement 

As a further step the VIs to execute a measurement must be added. 
 
In the previous driver version (Bode 100), an “Execute.vi” must be inserted and appended to the 
configure VIs (Figure 14) for starting a measurement. 
 

 
Figure 14: Previous driver (Bode 100) - Execution 

 
 
 
 
 

 
 

Figure 15: Current driver - Trigger configuration 
 
In the current driver version the “Configure Trigger.vi” and the “Send Trigger.vi” are employed to 
initiate a measurement (Figure 15). 
 
The “Configure Trigger.vi”, which sets the continuous measurement mode ON or OFF and the trigger 
source, can be found in the Bode VNA Driver palette (Figure 17). 
The “Send Trigger.vi” is in the Action-Status palette (Figure 16).  
 
The “Send Trigger.vi” generates a trigger regardless of the source selection.  
If the continuous mode is OFF, it makes one cycle and returns to the IDLE state.  
Otherwise, it switches to Waiting for trigger and starts a measurement again when a trigger is 
detected. 
For more information about how the trigger works, please refer to the Trigger Source Selection - SCPI 
command. 
 

 
 

 
Figure 16 Send Trigger.vi 

 
Figure 17 Configure Trigger.vi 

 
  

https://documentation.omicron-lab.com/BodeAutomationInterface/3.51/articlesScpi/commandReference/trigger/source.html?tabs=query-source%2Ccmd-source-python
https://documentation.omicron-lab.com/BodeAutomationInterface/3.51/articlesScpi/commandReference/trigger/source.html?tabs=query-source%2Ccmd-source-python
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After the hardware configuration, wire the trigger configuration. 
 

 
 Figure 18 Initiate measurement with trigger Block Diagram  

 

3.4.5  Receiving Measurement Results 

In the previous driver version (Bode 100), accessing the measurement results is handled by using two 
VI’s: (Figure 19) 

1. “GetGainResults.vi” (returns all gain measurement mode results) and  
2. “Results.vi”. 

 

 
 
 
 

Figure 19 Previous Driver (Bode 100) –  
Measurement results 

 
Figure 20 Current Driver – “ReadDataArray.vi” 

 
 

 
In the current driver version, the “Read Data Array.vi” (Figure 20) reads data from the instrument and 
splits it into a primary (Figure 22) and a secondary array (Figure 23). 
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In the previous driver version (Bode 100), the desired result can be accessed using "Unbundle By 
Name" (Figure 21).  
 

 
 

Figure 21 Previous Driver (Bode 100)-  
Gain Results Array 

 
 

Figure 22 Current Driver –  
Read Data Array (incl. Primary Results) 

 
In the current driver, "Bundle" is connected to the output "Read Data Array.vi" (Figure 22). 
To add the Bundle, right-click on the Block Diagram navigate to "Cluster, Class & Variant Palette" -> 
"Bundle". 
 
If next to the Primary also the Secondary results are needed wire as followed (Figure 23): 
 

 
Figure 23 Current Driver – Read Data Array Primary and Secondary Results 

 
 

In this case select the result type, which supports secondary data otherwise the secondary data would 
be zero see also chapter 3.4.2 Create and Configure a Measurement. 
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3.4.6  Display Results in XY Graph 

Now, we can reap the fruits of all the work and display the measured magnitude results in a linear 
frequency response diagram. Therefore, insert the “LabVIEW XY Graph” into the front panel using the 
function palette -> "Graph" -> "XY Graph" (see Figure 24). 
 

 
Figure 24: Insert XY Graph in Front panel 

 
As a result, an "XY Graph" indicator appears in the block diagram, which must be connected to the 
output of the result bundle (see Figure 25). 

 

 
Figure 25: Insert XY Graph in Front panel 

 
This “Bundle” is in the cluster function palette (Figure 26) 

 
Figure 26: Bundle 
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The axis labels of the diagram can be edited by double-clicking on the text (refer to the red framed 
boxes in Figure 27).  
Other properties, including axis scaling, the name of the curve, and the display format, can be 
adjusted by right-clicking on "XY Graph" -> "Property”. 

 

 
Figure 27: Change XY Graph Properties 

 
Before pressing the "Run" button, you can adjust the Sweep Settings and the Measurement/Hardware 
Setup settings. The green framed indicator shows the device type (Bode 100 or Bode 500) and the 
serial number of the connected Bode device. (Figure 27) 
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3.4.7  Disconnect Device 

As the last step of the process, always disconnect the Bode device by using the “Close.vi” (refer to 
Figure 28). 
 
Notice 
“Close Device” also unlocks the device. 

 
 

 
Figure 28: Bode Disconnect 
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4 Further information 

4.1   Accessing the Bode VNA Driver sub palette 

There are two common possibilities to access the Bode VNA Driver sub-palette: 
 

• Via the Function Palette (Figure 4)  
In the Block Diagram, open the right mouse context menu and select “Instrument I/O → 
Instrument Drivers → Bode VNA Driver → ....“ 

 
• Quick Access 

After you have placed at least one VI of the Bode VNA Driver library in the Block Diagram, the 
Bode VNA Driver sub-palette can be accessed easily by dragging the mouse over a VI. 
Therefore, press the right mouse button and select Bode VNA Driver Palette (Figure 29). 

 

 
Figure 29: Quick Access 
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4.2   Structure of the Bode VNA Series Instrument Driver 

 
Tree view of function palette 
 
To browse the VI structure of the OMICRON Lab Bode VNA Series Instrument Driver, change the 
palette to the Tree View (in the menu of the Function Palette, click: View → View This Palette As → 
Tree). 
 

 
Figure 30 Change View of Functions Palette 

 
Figure 31 Search Driver in Tree View 
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4.3   Getting Help 

To get a short description of the input and output connectors of each VI, activate the Context Help in 
LabVIEW, either via the Help menu or by pressing CTRL+H on the keyboard.  
 
Move the mouse over a VI to view its Context Help. 
 

 
Figure 32 Context Help View 
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4.4   Examples 

The package contains several examples demonstrating the usage of the "OMICRON Lab Bode VNA 
Series Instrument Driver”: 
 

• “Bode VNA Series Configuration Application.vi” 
• “Bode VNA Series Continuous Sweep Measurement.vi” 
• “Bode VNA Series Hello Bode.vi” 
• “Bode VNA Series Single Point Measurement.vi” 
• “Bode VNA Series Single Sweep Measurement.vi” 
• “Bode VNA Series Step by Step Gain Measurement” 
• “Bode VNA Series Sweep Measurement using Shaped Levels.vi” 
• “Bode VNA Series Thru Calibration.vi” 

 
The examples can be found 

• on your PC under 
<LabVIEW Installation Folder>\instr.lib\OMICRON Lab Bode VNA Series\Examples 

 
• Or by using the Example Finder of LabVIEW.  

Select „Find Examples“ from the LabVIEW Help menu to launch the Example Finder. 
Now select the Tab "Browse" and choose the folder "Hardware Input and Output → Instrument 
Drivers → LabVIEW Plug and Play". 
 

 
Figure 33: Example Finder 

 
You can also search for the OMICRON Lab Bode VNA Series examples by selecting the "Search" tab 
and entering one of the keywords like “Omicron Lab”, “Bode”, “VNA” or “instrument”. 
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4.5   Additional Information 

You can find additional information about all measurement modes and SCPI (Bode 100 and Bode 
500) in the Bode Automation Interface and SCPI reference available online at 
https://documentation.omicron-lab.com/BodeAutomationInterface/3.51/index.html 

4.6   Get support 

www.omicron-lab.com/support  
support@omicron-lab.com 
 
 

You can reach our application engineers and technicians at our technical support hotline free of 
charge for any inquiries.  

Americas:  +1 713 830-4660 or +1 800-OMICRON 
Asia-Pacific:  +852 3767 5500 
Europe / Middle East / Africa:  +43 59495 4444 
 
 

 

 
  

https://documentation.omicron-lab.com/BodeAutomationInterface/3.51/index.html
https://www.omicron-lab.com/support
mailto:support@omicon-lab.com
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Americas 
OMICRON electronics Corp. USA 
Phone: +1 713 830-4660 
Fax:  +1 713 830-4661 

Asia Pacific 
OMICRON electronics Asia Limited 
Phone: +852 3767 5500 
Fax:  +852 3767 5400 

Europe, Middle East, Africa 
OMICRON electronics GmbH 
Phone: +43 59495 
Fax:  +43 59495 9999 

info@omicron-lab.com  www.omicron-lab.com 

OMICRON Lab is a division of OMICRON electronics specialized in 
providing Smart Measurement Solutions to professionals such as 
scientists, engineers and teachers engaged in the field of electronics. 
It simplifies measurement tasks and provides its customers with more 
time to focus on their real business. 
 
OMICRON Lab was established in 2006 and is meanwhile serving 
customers in more than 50 countries. Offices in America, Europe, East 
Asia and an international network of distributors enable a fast and 
extraordinary customer support. 
 
OMICRON Lab products stand for high quality offered at the best 
price/value ratio on the market. The products' reliability and ease of use 
guarantee trouble-free operation. Close customer relationship and more 
than 30 years in-house experience enable the development of 
innovative products close to the field. 
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